How can we help?


netatmo error "Error: parser returned no values"

Comments

11 comments

  • Avatar
    RainMachine Nicholas

    I will make a note of this to check if we can receive battery information using the API that we use for NetAtmo.

     

    0
    Comment actions Permalink
  • Avatar
    Dewey72

    I am having the same issue and issued a trouble ticket. How do you reset this so Rain Machine stops throwing the error after you have replaced the batteries? 

    0
    Comment actions Permalink
  • Avatar
    RainMachine Nicholas (Edited )

    Hi Dewey.

    Either press DEFAULT from the web interface Setting > Weather > NetAtmo or change the username to something invalid, hit SAVE, then REFRESH ALL.

    Then go to NetAtmo settings again, put your correct username, hit SAVE and REFRESH ALL.

    This will initiate a auth reset for NetAtmo service and should work fine afterwards.

    Warning: Pressing DEFAULT will reset all NetAtmo parser data and settings.

    The beta update fixes this issue with NetAtmo.

     

    0
    Comment actions Permalink
  • Avatar
    Steven Besser

    I'm getting netatmo-parser errors with my newly installed Netatmo.  I've tried the Default and have tried to set up multiple time .... The RainMachine can see both of my Netatmo Modules, but it cannot pull any data.  What is the fix?

    2019-07-05 17:53:19,448 - ERROR - netatmo-parser:172 - Error reading temperature module: list index out of range
    2019-07-05 17:53:19,976 - ERROR - netatmo-parser:142 - Error reading rain gauge module: list index out of range
    0
    Comment actions Permalink
  • Avatar
    RainMachine Nicholas

    If you are using Web Interface, make sure you add your modules separated by comma (copy/paste each module ID to make sure you don't add any typos).

    0
    Comment actions Permalink
  • Avatar
    Gerhard Riegler

    I have the same Problem

    2019-09-02 20:11:22,395 - ERROR - netatmo-parser:172 - Error reading temperature module: list index out of range
    2019-09-02 20:11:22,697 - ERROR - netatmo-parser:142 - Error reading rain gauge module: list index out of range
    2019-09-02 20:11:23,012 - ERROR - netatmo-parser:152 - Error reading wind module: list index out of range
    2019-09-02 20:12:48,744 - INFO  - rmMainManager:239 - Upgrade checked.
    0
    Comment actions Permalink
  • Avatar
    Gerhard Riegler

    my Firmware version
    4.0.1125

    Please Help

    0
    Comment actions Permalink
  • Avatar
    Zack Nichols

    Has anyone had luck with this? I just got a Netatmo weather station hoping to link it with my RainMachine but it only ever says "Retrying: No data returned" in the status of the weather settings. And in the log its the same as the previous people have mentioned. I notice I got a HTTP Error 400 too.

    2019-11-15 22:54:01,345 - ERROR - netatmo-parser:172 - Error reading temperature module: list index out of range
    2019-11-15 22:54:01,371 - WARNING - rmParserManager:181 -   * Parser Netatmo Parser returned no values
    2019-11-15 22:56:41,265 - ERROR - netatmo-parser:172 - Error reading temperature module: list index out of range
    2019-11-15 22:59:44,362 - ERROR - netatmo-parser:261 - HTTP Error 400: 
    Traceback (most recent call last):
      File "./RMParserFramework/parsers/netatmo-parser.py", line 258, in postRequest
      File "/usr/lib/python2.7/urllib2.py", line 154, in urlopen
      File "/usr/lib/python2.7/urllib2.py", line 435, in open
      File "/usr/lib/python2.7/urllib2.py", line 548, in http_response
      File "/usr/lib/python2.7/urllib2.py", line 473, in error
      File "/usr/lib/python2.7/urllib2.py", line 407, in _call_chain
      File "/usr/lib/python2.7/urllib2.py", line 556, in http_error_default
    HTTPError: HTTP Error 400: 
    2019-11-15 22:59:44,390 - ERROR - netatmo-parser:222 - Failed to get oauth token
    2019-11-15 22:59:47,278 - ERROR - netatmo-parser:172 - Error reading temperature module: list index out of range
    2019-11-15 23:02:57,530 - ERROR - netatmo-parser:172 - Error reading temperature module: list index out of range

    Any help would be great. Thanks

    0
    Comment actions Permalink
  • Avatar
    RainMachine Nicholas

    Make sure you have the latest version of RainMachine firmware.

    Try to reset NetAtmo to DEFAULTS (by pressing the button from Web Interface), enable and enter your credentials again without selecting any modules (uncheck useSpecificModules). SAVE and REFRESH NOW for all weather services. Check the log/UI if it worked. 

    I just tried my personal NetAtmo now and it works fine.

    0
    Comment actions Permalink
  • Avatar
    olezha85

    Retrying: No data returned

    I tried all the options, deleted / added 10 times, but this does not help. Login Password = Passed.
    I have Homey, it receives data from NETATMO without problems, but Rainmachin does not want to receive it at all.

    2020-06-27 12:52:27,054 - INFO  - rmUserSettings:174 - ---------------------------------------------------------------------------------------------
    2020-06-27 12:52:27,073 - INFO  - rmThreadWatcher:143 - ThreadWatcher running True
    2020-06-27 12:52:27,085 - INFO  - rmLocalNetworkAdvertise:115 - Local Network Advertiser starting
    2020-06-27 12:52:27,147 - INFO  - rmParserManager:228 - *** BEGIN Loading parsers from './RMParserFramework/parsers'
    2020-06-27 12:52:27,192 - INFO  - rmParser:71 - *** Registering parser OpenWeatherMap Parser with interval 21600
    2020-06-27 12:52:27,408 - INFO  - rmParser:71 - *** Registering parser Netatmo Parser with interval 21600
    2020-06-27 12:52:27,615 - INFO  - rmParser:71 - *** Registering parser WUnderground Parser with interval 21600
    2020-06-27 12:52:27,814 - INFO  - rmParser:71 - *** Registering parser CIMIS Parser with interval 21600
    2020-06-27 12:52:28,009 - INFO  - rmParser:71 - *** Registering parser ForecastIO Parser with interval 21600
    2020-06-27 12:52:28,215 - INFO  - rmParser:71 - *** Registering parser Weather Rules Parser with interval 3600
    2020-06-27 12:52:28,508 - INFO  - rmParser:71 - *** Registering parser NOAA Parser with interval 21600
    2020-06-27 12:52:28,600 - INFO  - rmParser:71 - *** Registering parser FAWN Parser with interval 21600
    2020-06-27 12:52:28,792 - INFO  - rmParser:71 - *** Registering parser WeatherDisplay Parser with interval 21600
    2020-06-27 12:52:28,992 - INFO  - rmParser:71 - *** Registering parser METNO Parser with interval 21600
    2020-06-27 12:52:29,039 - INFO  - rmParserManager:313 - *** END Loading parsers
    2020-06-27 12:52:29,113 - INFO  - rmSimulator:1086 - Loading last weather simulation data for today programs
    2020-06-27 12:52:30,468 - INFO  - rmFlowSensor:44 - Initialised Flow Sensor with path /sys/devices/platform/rmsensor/flowcounter
    2020-06-27 12:52:30,540 - INFO  - rmAcquireData:46 - Init RMAcquireData
    2020-06-27 12:52:30,773 - INFO  - rmAPIClientREST:93 - REST: GET : http://127.0.0.1:18080/api//apiVer
    2020-06-27 12:52:30,850 - INFO  - rmTouchManagerRainMachine5:937 - Closing boot animation
    2020-06-27 12:52:30,963 - INFO  - rmTouchManagerRainMachine5:267 - Touch Manager is starting up ...
    2020-06-27 12:52:31,206 - INFO  - rmMainManager:139 - Starting bonjour service
    2020-06-27 12:55:45,506 - WARNING - rmParserManager:181 -   * Parser Netatmo Parser returned no values
    2020-06-27 12:56:55,904 - INFO  - rmMainManager:239 - Upgrade checked.
    2020-06-27 13:10:29,351 - INFO  - rmMainManager:239 - Upgrade checked.
    ---------------------------- PROGRAM SIMULATION LOG -----------------------------
    0
    Comment actions Permalink
  • Avatar
    RainMachine Nicholas

    Did you specify any modules and checked "Use Specified Modules" ? Did you configure from Web UI or mobile ?

    0
    Comment actions Permalink

Please sign in to leave a comment.