How can we help?


RainMachine8 Gen2: Cannot set wifi to DE (enable channels 12 - 13)

Comments

6 comments

  • Avatar
    Nicholas

    Does your setting stick without rebooting ? I tried on my Mini-8 and it changes.


    root@RainMachine:~# iw reg get
    country US: DFS-FCC
    (2402 - 2472 @ 40), (3, 27)
    (5170 - 5250 @ 80), (3, 17)
    (5250 - 5330 @ 80), (3, 24), DFS
    (5490 - 5600 @ 80), (3, 24), DFS
    (5650 - 5710 @ 40), (3, 24), DFS
    (5735 - 5835 @ 80), (3, 30)
    (57240 - 63720 @ 2160), (N/A, 40)

    root@RainMachine:~# iw reg set DE
    root@RainMachine:~# iw reg get
    country DE: DFS-ETSI
    (2400 - 2483 @ 40), (N/A, 20)
    (5150 - 5250 @ 80), (N/A, 20), NO-OUTDOOR
    (5250 - 5350 @ 80), (N/A, 20), NO-OUTDOOR, DFS
    (5470 - 5725 @ 80), (N/A, 27), DFS
    (57240 - 65880 @ 2160), (N/A, 40), NO-OUTDOOR

    root@RainMachine:~# dmesg
    [...]
    [173238.970000] cfg80211: Calling CRDA for country: DE
    [173238.990000] cfg80211: Regulatory domain changed to country: DE
    [173238.990000] cfg80211: DFS Master region: ETSI
    [173238.990000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    [173239.000000] cfg80211: (2400000 KHz - 2483000 KHz @ 40000 KHz), (N/A, 2000 mBm)
    [173239.010000] cfg80211: (5150000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 2000 mBm)
    [173239.020000] cfg80211: (5250000 KHz - 5350000 KHz @ 80000 KHz), (N/A, 2000 mBm)
    [173239.020000] cfg80211: (5470000 KHz - 5725000 KHz @ 80000 KHz), (N/A, 2700 mBm)
    [173239.030000] cfg80211: (57240000 KHz - 65880000 KHz @ 2160000 KHz), (N/A, 4000 mBm)









  • Avatar
    Alexandre

    Thanks. Before reboot it is showing DE, however channels 12-14 are not active. Unit will not connect to these channels.

    root@RainMachine:~# iw reg get
    country DE: DFS-ETSI
    (2400 - 2483 @ 40), (N/A, 20)
    (5150 - 5250 @ 80), (N/A, 20), NO-OUTDOOR
    (5250 - 5350 @ 80), (N/A, 20), NO-OUTDOOR, DFS
    (5470 - 5725 @ 80), (N/A, 27), DFS
    (57240 - 65880 @ 2160), (N/A, 40), NO-OUTDOOR

    root@RainMachine:~# iw list |grep MHz
    * 2412 MHz [1] (20.0 dBm)
    * 2417 MHz [2] (20.0 dBm)
    * 2422 MHz [3] (20.0 dBm)
    * 2427 MHz [4] (20.0 dBm)
    * 2432 MHz [5] (20.0 dBm)
    * 2437 MHz [6] (20.0 dBm)
    * 2442 MHz [7] (20.0 dBm)
    * 2447 MHz [8] (20.0 dBm)
    * 2452 MHz [9] (20.0 dBm)
    * 2457 MHz [10] (20.0 dBm)
    * 2462 MHz [11] (20.0 dBm)
    * 2467 MHz [12] (disabled)
    * 2472 MHz [13] (disabled)
    * 2484 MHz [14] (disabled)

    With country set to DE, could you check to see if your channels 12-14 are active?

  • Avatar
    Nicholas

    Mine shows disabled too not sure atm why they can no longer be enabled.

  • Avatar
    Alexandre

    Okay, so seems to me we are giving the right commands. But the unit it not activating the channels....

  • Avatar
    Nicholas

    Looks like the channels >11 are restricted in the wifi firmware because of some export regulations. We'll check if we can workaround this in the current firmware version.

  • Avatar
    Nicholas

    The enabling procedure is pretty complicated and involves editing directly on flash memory at certain locations. Not something users should do, let me see if we can come up with something safe to do without bricking the device.

Please sign in to leave a comment.