How can we help?


Set NTP Server to be used

Comments

3 comments

  • Official comment
    Avatar
    RainMachine Nicholas

    For Mini-8 you will have to edit the file /etc/config/system (using built in vi editor)

    For HD-xx there is no easy way.

    Comment actions Permalink
  • Avatar
    Josh D (Edited )

    Hi. 

    I have set the configuration as per below, saved the file (confirmed it saved by re-opening) and rebooted the device, 3 days later and the device is still out of sync. (about 20 mins out). I have NTP server on this IP, I have security cams that are all syncing without issue. Any suggestions? 

    config timeserver 'ntp'
            list server '0.172.24.11.2'
            list server '1.172.24.11.2'
            list server '2.openwrt.pool.ntp.org'
            list server '3.openwrt.pool.ntp.org'
            option enabled '1'
            option enable_server '0'

    Edit: note I have RainMachine behind a firewall with no access to the outside world / internet. The NTP server is on the same network / subnet. 

    Edit 2: Corrected the above to

    config timeserver 'ntp'
            list server '0.openwrt.172.24.11.2'
            list server '1.openwrt.172.24.11.2'
            list server '2.openwrt.pool.ntp.org'
            list server '3.openwrt.pool.ntp.org'
            option enabled '1'
          option enable_server '0'

     

    My firewall is still showing that it is attempting external NTP syncs. 

    0
    Comment actions Permalink
  • Avatar
    Josh D

    after some testing, it was the syntax I was using for list server (couldn't find much detail on the syntax)... the following worked. I hope this helps someone else. 

    config timeserver 'ntp'
          list server '172.24.11.2'
          list server '0.openwrt.pool.ntp.org'
            option enabled '1'
          option enable_server '0'
    0
    Comment actions Permalink

Please sign in to leave a comment.