How can we help?


Comments

11 comments

  • Avatar
    RainMachine Nicholas

    This will work only for HD-12/16 models not for Mini-8.

  • Avatar
    Trent Hanson

    There isn't a ssh key based login on the mini-8, it uses the incredibly insecure default password of rainmachine. Login: root, Password: rainmachine. I hope they fix this in a future update because of how absolutely insecure it is.

  • Avatar
    George

    I don't think SSH is enabled by default, and you can change the password after you log in the first time.

  • Avatar
    RainMachine Nicholas

    Yes, SSH is not enabled by default. After enabling it you should change the default password using passwd command.

  • Avatar
    Ralph Becker-Szendy (Edited )

    NOTE ADDED LATER: This is for an HD-16 model.

    Initially, I got the same error message "Invalid request" when uploading the ssh key.  It turns out that you have to copy *all* of the ssh key, including the "ssh-rss" at the beginning, and the identifier "RainMachine" (if you follow the example in the page linked above), then it works.

    It turns out that there is actually no need to generate a special key for the RainMachine.  If you already have an RSA ssh key, you can just use the existing key; it is typically stored in ~/.ssh/id_rsa.pub.

    Once you are able to log in: The resulting key is stored on /data/ssh/authorized_keys.  At this point, you can add other keys.  For example, I want multiple people to be able to log in, so I just copied their keys (by using scp to copy them into /tmp/ on the RainMachine), and then appended them to the existing authorized_keys, which contained the first key.  WARNING: the upload command in the linked document stores the key *without* a trailing newline!  Check for that before appending another key, otherwise you break the file format (or you are lucky like me, are already logged in, and can use vi to repair the file).

    So far, ssh works great.  On to the next task: Install the certificate so web browsers don't whine about the self-signed certificate ...

  • Avatar
    Marcus Steinbach (Edited )

    Like it is listed in the original post, I am getting the same error message: { "statusCode": 3, "message": "Invalid request !" }

    I have the Rainmachine Pro-16. It is installed using a physical ethernet cable and not using Wi-Fi. I have the unit programmed and working well. I can access the device remotely and locally.

    I understand as stated here that SSH is not enabled by default. I enabled SSH in the mobile iOS app and I can also access the RainMachine REST API web UI. I have also enabled and disabled with the Web  UI as well as the mobile app. I am using a Mac laptop to do everything.

    Using terminal I created a pair of SSH keys as instructed: ssh-keygen -t rsa -b 4096 -C "RainMachine" ; this created both the personal and public key files within my personal folder. I was half expecting it to be in the .ssh folder within my personal folder. Inside that folder is a single file names known_hosts.

    Once I have enabled SSH, rebooted and logged back into the Web UI I was able to locate the link for: POST dev/import/sshkey (SPK3 only). Then I am attempting to paste the RSA SSH Key String into the text field right below it. My string begins as: ssh-rsa AAAA  and continues ending with: /4dw== RainMachine

    I am including the beginning ssh-rsa and trailing RainMachine as someone also suggested within this thread. 

    After pasting the RSA SSH key string I click the link: POST dev/import/sshkey (SPK3 only) and I am promptly presented with { "statusCode": 3, "message": "Invalid request !" }

     

    I have tried rebooting after despite the error message. I have even attempted to SSH using putty and the Mac terminal with no success. Putty did appear to be working and make a connection. However both error out on authentication with the root/admin password. I am at a loss here. 

  • Avatar
    RainMachine Nicholas

    For Mini-8 and Pro-8/16 there is no need to upload a key, just enable ssh, login with root/rainmachine and once logged on change default password for ssh login with passwd root.

  • Avatar
    Ralph Becker-Szendy

    My notes above are for a HD-16, and I think following them on a Mini-8 or Pro-... may not work.

  • Avatar
    Scott Singhass

    Hi All,

    Similar to George's original post, I am following the same documentation to enable SSH on HD-16 on firmware 4.0.1115.

    Within the UI, I select enable SSH and select "apply", get the check mark but after refresh/reboot, SSH returns to disabled? When i attempt to use the documentation via the API:

    https://support.rainmachine.com/hc/en-us/articles/228652648-How-to-SSH-on-Touch-HD-2nd-generation-devices

    The API returns ok but after reboot, once again SSH is not enabled. I have tried factory reset but nothing has been successful enabling SSH.

    Any suggestions?

    Thanks - Scott

  • Avatar
    RainMachine Nicholas

    The UI doesn't keep the setting state but the SSH is enabled after you set it to Enable. Just try to ssh after you had enabled it.

  • Avatar
    Scott Singhass

    Good info...thank you! Will give it a try

Please sign in to leave a comment.