How can we help?


Mini-8 Acts as a Network Gateway

Comments

15 comments

  • Avatar
    Ian Coulthard

    Just checked here and another PC only has the right gateway defined via ipconfig

    0
    Comment actions Permalink
  • Avatar
    RainMachine Nicholas

    Interesting, we did have another similar report a year ago, and such is a very low incidence. 

    To debug more could you ssh to Mini-8 (Enable SSH from Settings > System) and issue /etc/init.d/dnsmasq stop ? After that you could restart your router and check if it the issue appears.

     

    P.S. This won't survive between reboots, and it's better so because without dnsmasq you will break the Access Point mode if you ever need to change the WIFI SSID that Mini-8 connects to. It will allow us to know about a potential resolution to this.

     

    1
    Comment actions Permalink
  • Avatar
    Josh

    I'll give it a try and let you know but obviously I would prefer a permanent fix. I'll also try using a dynamic ip address and see if that helps.

    0
    Comment actions Permalink
  • Avatar
    Josh

    I wasn't able to ssh into the mini-8. I never could figure out the correct user name or password. I tried both admin and root as the username. Is there some default? 

    Also, it wasn't obvious to me how to change the Mini-8 from a static IP address to a dynamic. Is there some procedure besides resetting to factory defaults?

    0
    Comment actions Permalink
  • Avatar
    Josh

    OK. I figured out the ssh password and issued the dnsmasq stop which appears to have fixed the problem. Still not clear on the procedure for changing the ip address.

    0
    Comment actions Permalink
  • Avatar
    Josh

    OK. I used the POST page to change it to DHCP. Doing that seems to have fixed the problem. I don't think it is broadcasting itself as a gateway anymore.

    0
    Comment actions Permalink
  • Avatar
    RainMachine Nicholas

    Hi Josh,

     Did you fix your issue by stopping dnsmasq and changing to DHCP or just changed to DHCP and it fixed it ?

     

    P.S. To set to static IP you can use the same API page but instead of writing dhcp in that field you write static and you set the static IP / netmask/ GW that you want.

    0
    Comment actions Permalink
  • Avatar
    Josh

    Stopping dnsmasq fixed it; however, I was concerned that the problem would reappear after rebooting the Mini-8. After confirming that stopping dnsmasq worked I also switched to DHCP and rebooted. The problem did not return. It could be that just switching to DHCP would have resolved it as well but I don't know.

    1
    Comment actions Permalink
  • Avatar
    Jbsylr (Edited )

    I'm the OP for this issue. I stop by the forum from time to time to check on this issue.   My router is an ASUS running ASUS-Merlin firmware.  I've also found this issue on my HP laptops and not my Dell laptops for the most part.   I believe this has something to do with firmware on Intel WiFi NICs.  Has this been added as a feature request?  The DHCP services really need to stop after the unit is assigned an IP.  If you save a backup prior to the dnsmasq change, will have factory reset restore the setting?  As mentioned in the caution, not wanting to brick my Mini after a network change.

    @Josh, you may want to be careful.  If the change persisted after the reboot, you may want/need to start it if you ever choose to change your SSID, move or have some other major network change.

    0
    Comment actions Permalink
  • Avatar
    drmm8 (Edited )

    This is indeed a problem. There is no reason to have another DHCP server on the network, this is very poor network configuration of RM. DHCP should be disabled once RM is not in AP mode.

    If you are skilled, RM runs OpenWRT. You can disable dnsmasq on it completely. If you reset it to factory defaults and try to reconfigure it your phone/PC won't be able to get an IP address from it via DHCP, but that's OK, you can assign a static IP 192.168.13.2 The default IP address of the RM is 192.168.13.1

    If you want to be advanced you can ssh in and edit /etc/rc.local (but only if you understand what you are doing and how to recover from it):

    # Put your custom commands here that should be executed once
    # the system init finished. By default this file does nothing.

    if [[ -r /rainmachine-app/has-connected-once ]]; then
    ( sleep 15; /etc/init.d/dnsmasq stop; ln -sf /tmp/resolv.conf.auto /etc/resolv.conf ) &
    fi

    exit 0
    1
    Comment actions Permalink
  • Avatar
    Jbsylr

    Thank you for the response, drmm8.  I wish this was incorporated into the device OOTB.  I thought about disabling dnsmasq, but was afraid I'd forget about it and brick it.  I like the if/then, but your right it is probably a little advanced for some since normies don't like SSHing into devices.  Thx, again.

    0
    Comment actions Permalink
  • Avatar
    Will Rosenberry

    on my pro 8 I had a problem with an RM was actually showing an SSID I think was named rainmachine, you could log in to it with no keys and get a 192.168.13.X address.  Tech support said the AP side of the unit should have shut off after I configured the WIFI on the RM to be a client.  they said it was because I did not following the directions the first time I turned it on (which may be true)

    They had me make a backup of RM, then reset it to factory defaults.

    I think I had to delete the object on my phone?

    than start the RM, than after wifi came up I had to start the app on my phone.

    the app than used my phone WIFI to connected to the RM (and was assigned 192.168.13.?)

    next I followed the setup and restored my backup.

    RM rebooted, and phone auto switched back to my home WIFI.

    once RM rebooted the AP side of the RM shut off and now its just a wifi client, not a WIFI AP.

     

    0
    Comment actions Permalink
  • Avatar
    drmm8

    The AP problem is discussed in this thread:
    https://support.rainmachine.com/hc/en-us/community/posts/360014600594-RainMachine-Pro-16

    It is buggy and doesn't always shut down at the end of the setup as it should.

    0
    Comment actions Permalink
  • Avatar
    Christian Olgaard

    I have the same issue 

    Trying to log in to Device using SSH  - what port should I use?

    0
    Comment actions Permalink
  • Avatar
    RainMachine Nicholas

    Normal ssh port (22) but you will have to enabled it first from the System Settings.

    0
    Comment actions Permalink

Please sign in to leave a comment.