How can we help?


firmware hung device

Comments

10 comments

  • Avatar
    RainMachine Support

    Hi, bluther
    We're sorry about that. It looks like a failure to load the Wi-Fi driver after the firmware update.

    As a troubleshooting steps, please do the following:

    1. Power down the RainMachine device
    2. Remove Wi-Fi thumbstick from the USB port
    3. Power on the RainMachine device

    If the unit started ok and reached the main HOME screen, next steps would be:
    4. Plug back the Wi-Fi thumbstick into the USB port
    5. The RainMachine will Restart itself and should load the Wi-Fi driver correctly after the firmware update.

    Thank you for your understanding,
    RainMachine Support

    0
    Comment actions Permalink
  • Avatar
    Corin

    I have the same issue. No problems since 2015 when we originally bought the system. Removed TP Link USB wifi adapter, unplugged, waited 60 seconds, plugged in, it spins on the watering can forever. Tried this 3 times. Hit the reset button which causes a reboot and goes into the same mode.

    Is there any way to trigger a diagnostic mode or anything to see exactly where it's getting stuck?

    0
    Comment actions Permalink
  • Avatar
    Corin

    Bluther, have you gotten yours fixed? Mine is still stuck despite everything I tried.  Submitted a request to customer support and waiting to hear back, but at this point feel my device is bricked through no fault of my own.

    0
    Comment actions Permalink
  • Avatar
    bluther

    No.  I had to send my in for repair / flash.  I ended up calling.  The customer support via email was slow and the incorrect solution.  After calling, they said it would take 7-10 days.  I had to call several times to follow up on receiving my proof of purchase and then the actual sending of the RMA information.

    0
    Comment actions Permalink
  • Avatar
    Corin

    Ah, thanks for the info. I have a request into them now so waiting to hear back. Proof of purchase might be a pain, it was all one big bill paid to the contractor when they were installing the sprinklers. Trying to decide if it's worth just switching to a Rachio for $200 <sigh>

    0
    Comment actions Permalink
  • Avatar
    Brandon Moyer

    I would like to extend our deepest apologies, for anyone experiencing the "Loading Screen" and are unable to boot, we would like to help you get back to a working state. Please call or email tech support and we will get you taken care of. We want to minimize down time as much as possible. 

    Thanks in advance for your time and patience.

    Brandon 
    RainMachine Support

    0
    Comment actions Permalink
  • Avatar
    daniel atha

    I’m having the same issue. Did support resolve anyone’s issue?

    0
    Comment actions Permalink
  • Avatar
    Corin

    They responded to my request similarly to what Brandon said above. I submitted a ticket explaining what was going on, and they have responded with the following:

    "Unfortunately it looks like we will need to Fix/Replace your unit and would like to start the RMA Process.
    If you could upload a copy of your Proof of Purchase, we can go ahead and get the process started.
    Thanks in advance for your time and patience."

    I'm appreciative of this, looks like they're going to take care of the problem which is all I can ask for. The catch is that I need to track down proof of purchase, so I'm contacting the installer to try to get this information.

    Sucks that this happened, firmware updates going bad and bricking a device is never fun for anyone, but hopefully this is a small percentage of their customers and they can figure out what went wrong and prevent it from happening in the future. Anyone else having this issue should contact RainMachine and get this process started, as Brandon states above. Don't rely on this forum to get the message to them.  Here's their main contact page where you can fill out a form to make the request: https://www.rainmachine.com/help.php

     

    0
    Comment actions Permalink
  • Avatar
    Corin

    Got my replacement device, they were quick to send it after I gave proof of purchase and sent a pre-paid return label to send the bricked unit back.  I'm back up and running after re-configuring the device for all our zones and programs. Will have to see about how to export all my settings in case this happens again... :)

    Thanks to RainMachine support for dealing with this.

    0
    Comment actions Permalink
  • Avatar
    bluther

    I got mine back in about a week.  Was able to restore a backup and had all of my zones and schedules back.   We only received about 6 inches or rain in the Dallas area while the device was getting repaired so it wasn't a big deal without it.   Hopefully they figure out why it got bricked and it doesn't happen in the future.  Would love a way to be able to flash by myself using the usb port so I don't have to send in for repair in the future.

    0
    Comment actions Permalink

Please sign in to leave a comment.