How can we help?


No Hostname of Device

Comments

6 comments

  • Avatar
    RainMachine Nicholas

    You are probably referring to DHCP Client name, which should show up as RainMachine, we'll look if any recent change didn't affect this.

    0
    Comment actions Permalink
  • Avatar
    PedroJorgePereira

    Hi Nicholas, I have the same issue. 

    My local DNS server registers the DHCP Client name / Hostname with a default name "new-host". 

    When I connect using SSH I can see the machine hostname as "RainMachine5"

    Regards,

    Pedro

    0
    Comment actions Permalink
  • Avatar
    George Shaw (Edited )

    Edit /etc/config/network and add the hostname option in the config for whichever connection you are using.

    1
    Comment actions Permalink
  • Avatar
    PedroJorgePereira

    Thank you George. Done and working.

    0
    Comment actions Permalink
  • Avatar
    Harsh W

    Does this work for RainMachine HD-12 ? I couldn't find the /etc/config/network file ...

    0
    Comment actions Permalink
  • Avatar
    George Shaw

    I do not have that model. The Pro 8/16 run OpenWRT. The HD-12 may be running something different. Could be /etc/sysconfig or /etc/network/interfaces.

    0
    Comment actions Permalink

Please sign in to leave a comment.