How can we help?


Cannot turn OFF WiFi / Cannot disable WiFi

Comments

22 comments

  • Avatar
    Will Rosenberry

    I had a similar problem on my pro where It kept broadcasting an SSID that was not secured.  My neighbor showed me this after he started connecting to it.  It did not allow him to get to internet but it was handing out a 192.168.13 address if I recall.  One difference is I use wifi and not ethernet

    support said that when I first turned it on I had a Ethernet cable plugged in (which may be true, I don't recall), than I moved it to Wifi and the SSID never turned off.

    they had me backup the unit, reset it to factory defaults, than connect to it with wifi app and follow directions, SSID went away. Maybe call them up and they will talk you threw it.

    0
    Comment actions Permalink
  • Avatar
    drmm8

    The network setup in the RM leaves a lot to be desired. RM needs to hire a networking expert.

    0
    Comment actions Permalink
  • Avatar
    lanbrown

    Francois,

     

    Did you see this thread?

    https://support.rainmachine.com/hc/en-us/community/posts/360014600594-RainMachine-Pro-16 

    0
    Comment actions Permalink
  • Avatar
    drmm8 (Edited )

    The OP is asking whether you can physically turn off the wifi radio so it doesn't emit any waves. I do not think it's possible to power off the radio. You may be able to hardware hack it, but not via software.

    0
    Comment actions Permalink
  • Avatar
    lanbrown

    When the Rain Machine is in AP mode, even if you disable the SSID broadcast, it still needs to broadcast beacon frames.  This is the case even with a hidden SSID.  If a device is configured to use a hidden SSID, it might try to connect to see if that is the hidden SSID it is looking for.  So a hidden SSID is not going to remove the beacon frames from being broadcasted out.  Disabling the AP mode will stop the beacons since the WLAN interface no longer has a configuration and thus has no need to even try to broadcast it.  Most likely the beacon frame is sent about every 100 milliseconds if AP mode was enabled.

     

    On my Rain Machine, if I print out the interfaces, it only lists eth0 and l0.  It doesn't list anything for the WLAN interface.  I also cannot see it listed from my WLC.  I have four active AP's, each with an advanced security module that constantly scans the 2.4 and 5GHz bands using a dedicated radio and there is also two AP's in monitor mode that scan the 2.4GHz and 5GHz bands using their dedicated radios (one for 2.4GHz and the other for 5GHz.)  Not a single one of them sees the Rain Machine at all.  They see plenty of other AP's and client devices (even ones not connected to any of my networks) since there are eight dedicated radios constantly scanning the airwaves.

    So while the radio is still powered on, there is nothing for it to send or try to connect to and essentially nothing should be transmitted.

    0
    Comment actions Permalink
  • Avatar
    drmm8

    That's all fine, but unless you completely power off the radio I doubt there is no RF leak.

    0
    Comment actions Permalink
  • Avatar
    Will Rosenberry

    there is an AccessPoint on the rain machine that is used to configure the device from your cell phone with Rain Machine app the first time you start the device.

    Once you are compete doing the setup, the AP reboots, when it restarts the Access Point in the RM shuts off and the RM becomes  a client on your home network.

    call Tech support, they can talk you through it by doing a backup, factory reset, then using phone connect to RM AP, restore backup, it reboots and AP goes away.

     

    0
    Comment actions Permalink
  • Avatar
    kujulu

    I did just that (backed up, factory reset, restore backup, reboot, etc), and while the constantly blinking Wifi LED went away on my Pro-16, the AP eventually came back.

    0
    Comment actions Permalink
  • Avatar
    drmm8 (Edited )

    kujulu - are you setting it up via Android or iOS app? I can repeat the problem using my Android phone but not with an iPad. There's something about the Android app, the request to disable the AP does not make it to the unit.

    You can use the REST API to disable the AP if it's easier than ssh (though I have not tried it):

    http://<IP>:8081/api/4/

    (replace <IP> above with the IP address of the unit)

    Enter the password in the first box then click on POST auth/login

    Scroll down until you see Enable/Disable AP Mode and make sure the checkbox next to it is unchecked

    Click on POST provision/wifi/ap

    Report back if it worked, I have not tried it myself.

    0
    Comment actions Permalink
  • Avatar
    kujulu

    drmm8 - I'm on iOS. Just can't get my Pro-16 to connect via wifi, and so cannot make the AP disappear permanently.

    Going to try your SSH method and see how that goes. The REST API instructions you gave don't seem to return anything on my Pro-16.

    0
    Comment actions Permalink
  • Avatar
    BB

    When using the REST API instructions on my Pro-16, I do get an OK return message when running the  POST provision/wifi/ap  command.

    However, I get the following results when I run the   GET provision/wifi   command to verify:

    {
    "macAddress": "xx:xx:xx:xx:xx:xx",
    "ssid": null,
    "netmaskAddress": null,
    "hasClientLink": false,
    "mode": "ap",
    "interface": "ra0",
    "lastWIFICheckTimestamp": 156099346435,
    "ipAddress": "192.168.13.1"
    }

     

    I can see that the ssid is set to null which is good, but it is showing the mode is still "ap".

    Is this the correct results?

     

     

     

    0
    Comment actions Permalink
  • Avatar
    drmm8

    Doesn't look right, should see something like:

    ...
    "hasClientLink": true, "mode": "managed", "interface": "apcli0",
    ...
    0
    Comment actions Permalink
  • Avatar
    BB

    Just to clarify, I'm using the Ethernet connection only. 

     

    I went ahead and got SSH working and the uci show wireless command returns the following result.

    It appears the two items that were recommended to be changed are configured correctly.  But it looks like a lot of other config remains intact.

    wireless.ap.encryption='psk2'
    wireless.ap.hidden='1'

    I'll have to go out to my RainMachine to verify the SSID is hidden, but it would be great to eliminate it all together.

     

    root@RainMachine5:~# uci show wireless

    wireless.radio0=wifi-device
    wireless.radio0.type='ralink'
    wireless.radio0.variant='mt7628'
    wireless.radio0.country='US'
    wireless.radio0.hwmode='11g'
    wireless.radio0.htmode='HT20'
    wireless.radio0.region='1'
    wireless.radio0.channel='6'
    wireless.radio0.disabled='0'
    wireless.radio0.linkit_mode='apsta'
    wireless.ap=wifi-iface
    wireless.ap.device='radio0'
    wireless.ap.mode='ap'
    wireless.ap.network='ap'
    wireless.ap.ifname='ra0'
    wireless.ap.ssid='RainMachine-00xxxx'
    wireless.ap.hidden='1'
    wireless.ap.encryption='psk2'
    wireless.sta=wifi-iface
    wireless.sta.device='radio0'
    wireless.sta.mode='sta'
    wireless.sta.network='wifi'
    wireless.sta.ifname='apcli0'
    wireless.sta.led='rainmachine:white:wifi'

    0
    Comment actions Permalink
  • Avatar
    drmm8

    The settings look OK, you can reboot to make sure they are applied, or run "wifi reload" via SSH and check that there's no AP broadcast. Also run "wifi status".

    Alternatively, you can look in the thread below, you can comment out the ap sections from /etc/config/network and /etc/config/wireless and reboot. I think it's an aggressive config change that may cause problem in the future, but it's another option if you know how to recover from it:
    https://support.rainmachine.com/hc/en-us/community/posts/360014600594/comments/360001672673

    0
    Comment actions Permalink
  • Avatar
    lanbrown

    You can also change the following setting to 1 which would also disable the radio:

    wireless.radio0.disabled='0'

     

    It won't really be disabled at the hardware level, but at a software level.

    0
    Comment actions Permalink
  • Avatar
    BB

    I did see the more aggressive approach but it didn't seem like RainMachine support was endorsing it.  I'd like to stick with the supported API as long as it is working correctly. If the other approach can be fully tested including reverting with a factory reset, RainMachine should just incorporate it into the API.

     

    0
    Comment actions Permalink
  • Avatar
    BB

    For reference here is my wifi status command result after turning off the AP using the POST provision/wifi/ap  API command and a reboot:

    radio0:
    up: true
    pending: false
    autostart: true
    disabled: false
    retry_setup_failed: false
    config:
    variant: mt7628
    country: US
    hwmode: 11g
    htmode: HT20
    region: 1
    channel: 6
    channel: 6
    disabled: false

    interfaces:

    section: ap
    ifname: ra0
    config:
    mode: ap
    ifname: ra0
    ssid: RainMachine-00xxxx
    hidden: true
    encryption: psk2
    mode: ap
    network:
    ap

    section: sta
    ifname: apcli0
    config:
    mode: sta
    ifname: apcli0
    led: rainmachine:white:wifi
    mode: sta
    network:
    wifi

    0
    Comment actions Permalink
  • Avatar
    drmm8 (Edited )

    You have to be careful what OpenWRT files you change as a factory reset does not restore them all, only some settings. It's very easy to be left with a bricked unit. This is another fail on the RM part, a factory reset must reset to the factory image, including to the default OpenWRT config, it should not be just a partial reset.

    The safe bet for now is to set the AP to hide the SSID, set encryption to PSK2 with no password set.

    For my unit I run a custom script from /etc/rc.local where I change and turn off other things. But it's conditional, it only runs if the file /rainmachine-app/has-connected-once exists which means that the unit has been set up. This file gets deleted when you reset to factory so my script won't run if I need to reset and start clean.

    0
    Comment actions Permalink
  • Avatar
    lanbrown

    You keep talking about bricking the unit.  The only people that care about disabling the wireless interface are the ones using the wired interface.  Since the wired interface is not being touched, please explain how the unit can be bricked?  If you cannot, please stop with the FUD.

     

    Without a doubt, one of the files that is being modified will without a doubt be changed back to factory defaults.  How is that known, it gets changed (or should be changed) with the app to change the wireless interface.  This is also the same file that the API is changing.  So, just that file could be modified and as such, if a reset is performed, the changes get reverted.  If they aren't, then it wouldn't be a reset since it wouldn't be reverting the changes the API made itself.

     

    My unit has received several firmware updates and it is still reachable via Ethernet and the wireless interface has not returned.

    0
    Comment actions Permalink
  • Avatar
    drmm8

    Say there is a botched firmware update that somehow disabled the ethernet interface. Then what? Always good to have a fallback. Sounds like gambling to me, but your device, your $$, do as you please but I don't think it's reasonable to encourage others to do the same, they should be aware of the potential dangers.
    Have you looked at the python code to see what really happens when you reset the unit?

    0
    Comment actions Permalink
  • Avatar
    lanbrown

    That is the poorest excuse ever.  What if there is a botched firmware for the Mini or the HD series and it caused the wireless interface to fail.  Then what??????  They only have the single interface.

     

    Shouldn't the firmware updates be at least somewhat tested, Beta or not.  The interface functionality would be one of the core devices.  From what support said, it sounds like both interfaces are well, using the same driver package.  So if there was an update to the driver package and it was was not implemented properly, chances are, both interfaces are going to be down.

     

    You still haven't proven that my changes are not reversed on a reset.  As I mentioned previously, one of the files is touched when you configure the wireless interface or via the API.

     

    Tell you what, you could get into an accident when you leave your house.  So to keep from being injured or killed, why don't you stay inside?  Actually, your house to catch on fire, so better not stay in the house, better get out.  Oh, maybe a meteorite will come crashing down on you, so better not be outside.

     

    If someone decides to follow my instructions, they made a decision.  Here is an idea, why don't you let people make their own decisions without you spreading FUD to influence them.  They are an adult and fully capable of making decisions!

    0
    Comment actions Permalink
  • Avatar
    RainMachine Nicholas

    There should be less heated debated once we rightly fix this at the end of setup and give the users, who still have it open from a previous installation, the option to disable it from mobile apps/local interface (actually an alert will pop up on mobile app if you have it open). 

    The current way (with the API) while not 100% correct (actually the interface should be down completelly) it still makes the AP non-visible and non-connectable.

    0
    Comment actions Permalink

Please sign in to leave a comment.