How can we help?


Remote access not working after moving rainmachine to new subnet

Comments

7 comments

  • Avatar
    RainMachine Nicholas

    You need to allow outbound to port 8000 (to Amazon AWS servers but this might be difficult to control)

     

    0
    Comment actions Permalink
  • Avatar
    Rmilewsk (Edited )

    All outbound connections to the internet are enabled. I'm only blocking traffic from my IoT network to all internal LANs. Are there any ports that need to be enabled from the IoT vlan to the internal LANs that I have my contolling devices (ipad, android phone) on? I was able to see and control the rainmachine using remote access and direct access when I moved my ipad to the IoT network. I'm guessing something has to be enabled between my IoT network and internal trusted networks. 

    I figured this was something not setup properly between my IoT subnet and trusted subnet because everything worked properly after I moved the rainmachine back to my trusted subnet. 

    0
    Comment actions Permalink
  • Avatar
    Rmilewsk

    I also read online that the device discovery will never work unless the device looking for the rain machine is on the same subnet. Is that correct? 

    0
    Comment actions Permalink
  • Avatar
    RainMachine Nicholas

    Yes, device discovery only works on same subnet but this is only for local network access. For access over internet it will be discovered by querying our servers using port 8000.

    If you with to access RainMachine without going through internet between the IoT VLAN and LAN you will need to allow 443/8080(https) and optionally 80/8081 (http) inbound to IoT VLAN.

    That's all the ports involved for UI access. 

    0
    Comment actions Permalink
  • Avatar
    Rmilewsk (Edited )

    Direct access works fine its only remote access that isn't working. Is only port 8000 needed for remote access? If so port 8000 needs to be opened between the rainmachine and aws? I'm looking for which devices need to have which ports opened between that device and wherever they are talking to. I'm looking for source and destination for the traffic. 

    0
    Comment actions Permalink
  • Avatar
    Rmilewsk

    It may be working now. I didn't turn on my firewall rule for port 8000 but I did enable the igmp snooping and the mdns multicast dns. Do you know if either of those are needed on the unifi gear? 

    0
    Comment actions Permalink
  • Avatar
    RainMachine Nicholas

    I'm not sure, when you say the remote access didn't work were you referring to the mobile app or https://my.rainmachine.com ?

    The entire list of ports used is here: https://support.rainmachine.com/hc/en-us/articles/228019128-Cannot-Connect-to-RainMachine

    0
    Comment actions Permalink

Please sign in to leave a comment.