How can we help?


Ethernet

Pinned Featured Implemented

Comments

102 comments

  • Official comment
    Avatar
    Nicholas (Edited )

    With the upcoming beta (version > .920) using usb to ethernet adapters works but this is *officially unsupported*.

    Most of the USB 2.0 adapters should work, especially those who market compatibility with Windows XP without installing any drivers. For a short list see the end of this post.

    To use ethernet just plug the usb to ethernet adapter in the spare USB port *without* physically removing the WIFI adapter.  You can use the Settings >System > WIFI to disable the WIFI from the software. After reboot the ethernet should be working.

    Known issues:

    1. The ethernet only works with DHCP there is no easy way to configure static IP.

    2. WIFI stick needs to be left inserted in the USB port.

    3. On device Network Tools output doesn't work for ethernet

    4. Can't start updates from device. Updates can be started from mobile/web applications

    5. On certain cases the device might not appear on local discovery from mobile apps. To workaround, you can use Direct Access from Network Settings (from mobile apps Devices screen) to specify <device IP:8080>.

    Adapters listed as compatible (some adapters might have newer versions that might not work):

     Linksys USB200M
     Netgear FA120
     DLink DUB-E100
     Intellinet, ST Lab USB Ethernet
     Hawking UF200, TrendNet TU2-ET100
     Billionton Systems, USB2AR
     ATEN UC210T
     Buffalo LUA-U2-KTX
     Buffalo LUA-U2-GT 10/100/1000
     Sitecom LN-029 "USB 2.0 10/100 Ethernet adapter"
     corega FEther USB2-TX
     Surecom EP-1427X-2
     goodway corp usb gwusb2e
     JVC MP-PRX1 Port Replicator
     ASIX AX88772B 10/100
     ASIX AX88772 10/100
     ASIX AX88178 10/100/1000
     Logitec LAN-GTJ/U2A
     Linksys USB200M Rev 2
     0Q0 cable ethernet
     DLink DUB-E100 H/W Ver B1
     DLink DUB-E100 H/W Ver B1 Alternate
     Linksys USB1000
     IO-DATA ETG-US2
     Belkin F5D5055
     Apple USB Ethernet Adapter
     Cables-to-Go USB Ethernet Adapter
     ABOCOM for pci
     ASIX 88772a
     Asus USB Ethernet Adapter
    TechRise Ethernet Adapter, USB 2.0 to RJ45 Fast Ethernet LAN Network Adapter

    If you find other working adapters let us know so we can add it to this list.

     

    Link the the beta changes:  https://support.rainmachine.com/hc/en-us/articles/230333608

  • Avatar
    Brandon Moyer

    I agree this would certainly solve long range WiFi issues with the ability to plug in a Ethernet cable. 

    Lets get some more votes on this!

  • Avatar
    plsjr

    This is an important capability to me. Ethernet connectivity should be a relatively straightforward implementation, even on the existing systems, if the "Wifi antenna" actually connects to a real USB port.

  • Avatar
    RichardP

    I am fairly certain the port is a full USB implementation. The issue seems to be with the Ethernet drivers, which appear to be missing.  Perhaps someone from Rainmachine will comment.

  • Avatar
    Nicholas

    The drivers for USB-Ethernet exist but Android doesn't actually support ethernet so there is not easy way to configure.

    There are ways of configuring the ethernet by logging in with ssh and using netcfg command but it's not something end users would do.

    We know that at least Apple USB Ethernet adapter works in this way.

     

  • Avatar
    RichardP

    Thanks for the info.  I have a couple of adapters that should work and will give that a try this fall when I am back in the location where the rainmachine is installed.  In the meantime, all is running fine.

  • Avatar
    Gary T. Giesen

    Would love to see some sort of support for Ethernet as well (preferably native, but a USB-to-Ethernet solution would suffice as well). Lack of Ethernet support is what's holding me back from buying a RainMachine now, and forcing me to look at alternative offerings.

  • Avatar
    Mitul Patel (Edited )

    How about Ethernet over power-line? It's not fast but should be good enough for this device.

    I think some other irrigation system have this capabilities.

  • Avatar
    Gary T. Giesen (Edited )

    To do Ethernet over Powerline, you first need to have an Ethernet port. Ethernet over Powerline typically just involves running a patch cable from the Ethernet port to an Ethernet over Powerline bridge (something like this: http://www.ca.netgear.com/home/products/networking/powerline/PL1200.aspx)

    Lots of things are possible once you have an Ethernet jack (such as using a Ethernet to WiFi bridge), but very little is possible when WiFi is your only option.

    One of my biggest gripes about WiFi-only devices (even setting aside the reliability issue) is that WiFi standards evolve and are deprecated much more quickly than Ethernet. I could plug an Ethernet device from 25 years ago into a modern Ethernet switch and it'd still work perfectly, without slowing down the rest of the clients.

    The same can't be said of WiFi, when the user upgrades their AP, etc. Enabling compatibility modes slow down the WiFi for all clients, not just older devices. And if your device doesn't support the latest version of WEP/WPA, then you're forced to either downgrade the security on your WiFi just so that one device can connect to it, or you have to spin up another SSID or AP just for that device.

    In short, IMHO every home automation device (that speaks IP) should have an Ethernet port. If you want add WiFi on top of that, go for it.

  • Avatar
    Gary T. Giesen

    Nicholas,

    Not sure what version of Android that RainMachine is running, but supposedly Marshmallow (6.0) includes support for configuring Ethernet (although you may still need to add the drivers)

  • Avatar
    RichardP

    I think we need to differentiate between having the rainmachine support a wired ethernet connection, and the transport layer used for that connection (I.e. EoP, 10-bast-T, 1000-base-T, etc.  How you get the ethernet to your rain machine is an issue outside the development scope of the rainmachine developers.

    Also, while it would be nice to have an actual RJ-45 connector onboard the rainmachine, that is not likely to happen anytime soon or at all. It would require a circuit board and case change that costs money and does not benefit many users.

    But, Nicholas has already given us everything we need to know to get wired ethernet working right now on the HD models using a common USB to ethernet adapter.

    Hopefully, someone will post a list of specific adapters known to work and configuration guide to enabling ethernet through the Android shell. If nobody has done so by the fall, when I will have time, I will do it.

  • Avatar
    Gary T. Giesen

    I don't particularly care if the Ethernet support is through a USB adapter or not, my biggest concern is making sure it's officially supported and hopefully configurable through something other than the Android shell. Not that I'm scared of the Android shell, but my priority is to get something robust and easy to use (ie. my wife could configure it if she had to).

  • Avatar
    Nicholas

    I'm gathering a list of adapters that work without any updates on HD-12/16, any help would be appreciated.

    Theoretically the steps are:

    1. Replace WIFI with USB Ethernet adapter (the other port can be used too along with WIFI adapter)

    2. SSH to HD12/16 (https://support.rainmachine.com/hc/en-us/articles/228652648-How-to-SSH-on-Touch-HD-2nd-generation-devices)

    3. Enter the following commands:

    su -
    netcfg eth0 dhcp
    ip route del default
    ip route add default via <gateway ip> dev eth0


    Use netcfg and ip route show to list information about devices / routing. To preserve this settings after reboot you can add the above commands (except su -) to a startup script:

    vi /system/bin/rainmachine.sh

    The commands should be added on top after the #!/system/bin/sh line.

     

     

  • Avatar
    RichardP

    Nicholas, thanks a million.

    Gary, I see your point about using the shell as a low WAF solution. But, you really only have to do it once. and if you use dhcp, as suggested above, any future changes can be made via a dhcp server. BTW, I can see how it would be simple to add the option to the GUI. But, I can also see the support nightmare from people who tried non-supported hardware.

  • Avatar
    RichardP

    I had a slight change in strategy and now have a rainmachine touch hd16 at my location. So today I tried to set it up on Ethernet. I am using an Apple A1277 Ethernet adapter.  The rain machine immediately recognizes the adapter. But, I then run into a problem trying to set it up for dhcp. The command "net eth0 dhcp" just hangs and I have to Ctrl-C to get out.  This also failed when entered in rainmachine.sh. However, I was able to use...

    ifconfig eth0 up 192.168.5.100 netmask 255.255.255.0

    And that worked.  Then after adding the default route, all was more or less well. Adding the ifconfig command into rain machine also worked.  But, I'd still prefer to use dhcp.  Any ideas what is going on?

    I also ran into another issue. If I disable and remove the wifi adapter, the Ethernet interface is also disabled. This is not a huge problem. But, it would be nice to not have to use the WiFi adapter.

     

  • Avatar
    Nicholas

    I will have to redo the setup and test again. Indeed the WiFi adapter must be enabled.

    The hang might be related to either /etc/dhcpcd/dhcpcd-hooks/ scripts or because of an existing lease in /data/misc/dhcp/ (less probable)

     

  • Avatar
    RichardP

    Nicholas. Thanks for the reply. And... another small problem.  rainmachine.sh gets replaced on each system upgrade. Is there another more permanent location for the net commands that might also work?

  • Avatar
    Nicholas

    I hit the same issue as Richard when doing the test again but I managed to get a dhcp IP by using:

    dhcpcd -ABKL -dd eth0

     

    When using this into the rainmachine script remove -B so it can enter background. I'll see if I can make a perfect setup pattern and check if we can integrate this for end users.

  • Avatar
    Joe Rankin (Edited )

    Has anyone here used USB to ethernet adapters other than the Apple one successfully? I will be getting an HD-12 soon and would like to set it up as a wired connection.

    Thanks.

  • Avatar
    Nicholas

    I'm only testing with Apple one, but I intent to create an unofficial package (to gather more feedback) that does all the ethernet setup automatically and add a driver that supports multiple USB adapters.

  • Avatar
    Jeff

    Adding another vote for officially supported ethernet connection or specified adapter.    

  • Avatar
    Joe Rankin

    I bought a Pix-Link LV-UE01 from Amazon https://www.amazon.com/PIX-LINK-Extender-300Mbps-Adapter-Repeater/dp/B01KQ3E88K/ref=sr_1_7?ie=UTF8&qid=1497556320&sr=8-7&keywords=PIX-LINK 

    I set it up as an AP with a static IP address, plugged it into my RainMachine Touch HD12, and it worked. I realize I am still using wireless for the Rainmachine to communicate with the Pix-Link, but this might be a solution for someone whose unit is far away from their wireless router. It also gives me a great wireless signal out in my garage.

  • Avatar
    Joe Rankin

    BTW should the TP Link adapter just pull out? I was going to play with this to see if I could get it to work without the TP Link but it seems very tight and I didn't want to break it.It looks like it's just in a USB port.

  • Avatar
    Vlad Yaglamunov

    I did everything as Nicholas said and its worked. However its looks like for remote access it uses wifi no matter what. So its working only in my local network. Ill try to set up vpn but there should be better solution.

  • Avatar
    Ben

    Anyone tried a TPLink UE200 or UE300?

  • Avatar
    Jim Smith

    @Joe Rankin  -  Joe, is your Pix-Link solution still working and standing up to the heat of the garage?  Is it reliable or do you get network drops? Any other problems?

    m looking to buy the same device and run a cable like you did, and just want to make sure you're still happy with this solution.

    Thanks!

    -Jim Smith

     

  • Avatar
    Joe Rankin

    Yes, it has been working fine for me without any issues. It is pretty basic and there are no updates or real support available for it, but for $15 I can't complain.

  • Avatar
    Gary T. Giesen

    Nicholas,

    Any word on that package you're working on to get semi-official support?

  • Avatar
    Nicholas

    We've done the package with the drivers but we're on hold because the cloud remote access will reject Ethernet connections because of some protection scheme.

    We want to solve this issue first before releasing this update so users can still benefit from remote access even if they use Ethernet.

  • Avatar
    Gary T. Giesen

    Any updates on this?

Please sign in to leave a comment.